关于CPU处理器内核存在Meltdown和Spectre漏洞的安全公告(第三版) - 福州ag九游会真人网络-福建IDC企业!专注云主机及服务器租用托管13年!

ag九游会真人

  • <tr id='5a6du'><strong id='5dn4'></strong> <small id='2yo9'></small><button id='jrl2qp'></button><li id='svex'> <noscript id='4kv5'><big id='ghs0'></big><dt id='yb2od'></dt></noscript></li></tr> <ol id='vn7k94'><option id='6th48'><table id='59qv2'><blockquote id='7iqv6'> <tbody id='13g4h'></tbody></blockquote></table></option></ol><u id='1elu9g'></u><kbd id='tkoq5'> <kbd id='tjtcgq'></kbd></kbd>

    <code id='os5r'><strong id='30m3u'></strong></code>

    <fieldset id='jffhi9'></fieldset>
          <span id='w5fiuo'></span>

              <ins id='rozth'></ins>
              <acronym id='6kd4h'><em id='pjce3'></em><td id='yck0o6'><div id='v3ys2l'></div></td></acronym><address id='i6eblf'><big id='234r8o'><big id='vovi'></big><legend id='gedf'></legend></big></address>

              <i id='rmf90'><div id='xe5w'><ins id='82eix'></ins></div></i>
              <i id='3jgz'></i>
            1. <dl id='jl1y44'></dl>
              1. <blockquote id='mrj4b'><q id='pp4yo'><noscript id='2182u3'></noscript><dt id='tqliu7'></dt></q></blockquote><noframes id='tmnfnh'><i id='nbdp1'></i>
                ag九游会真人动态 行业新闻 活动专题

                关于CPU处理器内核存在Meltdown和Spectre漏洞的安全公告(第三版)

                安全公告编号:CNTA-2018-0004

                1月4日,国家信息安全漏洞共享平台(CNVD)收录了CPU处理器内核的Meltdown漏洞(CNVD-2018-00303,对应CVE-2017-5754)和Spectre漏洞(CNVD-2018-00302和CNVD-2018-00304,对应CVE-2017-5715和CVE-2017-5753)。利用上述漏洞,攻击者可以绕过内存访问的安全隔离机制,使用恶意程序来获取操作系统和其他程序的被保护数据,造成内存敏感信息泄露。

                一、漏洞情况分析

                现代的计算机处理器芯片通常使用“预测执行”(Speculative Execution)和“分支预测”(Indirect Branch Prediction)技术实现对处理器计算资源的最大化利用。但由于这两种技术在实现上存在安全缺陷,无法通过正确判断将低权限的应用程序访存与内核高权限的访问分开,使得攻击者可以绕过内存访问的安全隔离边界,在内核中读取操作系统和其他程序的内存数据,造成敏感信息泄露,根据获取到的数据,可能会导致用户的数据隐私泄露、登陆凭证被攻击者窃取。具体信息如下:

                1)Meltdown漏洞利用破坏了用户程序和操作系统之间的基本隔离,允许攻击者未授权访问其他程序和操作系统的内存,获取其他程序和操作系统的敏感信息。

                2)Spectre漏洞利用破坏了不同应用程序之间的安全隔离,允许攻击者借助于无错程序(Error-Free)来获取敏感信息。

                具体的漏洞攻击场景如下:

                1)单台物理主机:低权限的攻击者利用漏洞,可访问本地操作系统的内核空间,进一步实现提权或命令执行等操作。

                2)云服务虚拟机:攻击者利用漏洞可以绕过虚拟机的隔离防护机制,访问其他租户的内存数据,导致其他云租户的敏感信息泄漏。

                3)网页浏览器:利用浏览器的即时编译器(Just-In-Time Compiler)特性,执行恶意代码,读取浏览器内存数据,导致用户账号、密码、邮箱、cookie等信息泄漏。

                受影响个体

                利用风险点

                个人用户

                网页浏览器执行恶意脚本

                配合其他低权限的漏洞执行代码

                服务器用户

                远程上传、执行恶意代码后利用

                云服务用户

                被位于同台物理主机、具有代码执行权限的其他云租户攻击

                CNVD对该漏洞的综合评级为“高危”。目前该漏洞的本地利用代码(POC)已经发布并验证成功,但能够远程利用的执行代码尚未发布,CNVD秘书处正联合技术组成员单位对相关情况做进一步的验证和分析,后续结果将进一步通报。

                二、漏洞影响范围

                该漏洞存在于英特尔(Intel)x86及x64的硬件中,在1995年以后生产的Intel、AMD、ARM处理器芯片受此漏洞影响,具体受影响的型号列表请参考厂商公告。

                1)Intel://www.jiau100.com

                2)AMD://www.dlhfay.com

                3)ARM:https://developer.arm.com/support/security-update

                同时使用这些处理器芯片的操作系统(Windows、Linux、Mac OS、Android)和云计算设施(亚马逊、微软、谷歌、腾讯云、阿里云等)也受此漏洞影响。

                三、处置措施

                目前,操作系统厂商通过在其产品内核引入内核页面隔离(KPTI)技术来修复Meltdown和Spectre漏洞。CNVD建议用户密切关注操作系统、虚拟机、浏览器等产品官方网站发布的安全公告,并及时下载补丁进行更新。各厂商的修复情况和参考链接如下:

                微软:已为windows 10已供修复包,并对windows 7和windows 8进行在线更新(//www.kyaz.net:80)。浏览器安全补丁已发布(//www.029chengren.com:80);

                苹果:IOS 11.2和macOS10.13.2及tvOS 11.2中加入了保护措施;

                谷歌:已于2017年12月向各手机厂商发布了安全补丁包,并发布安全公告(https://source.android.com/security/bulletin/2018-01-01)。1月23日发布的Chrome64浏览器将包含相应的保护机制(//www.lsqp6.cn);

                RedHat:已发布补丁(//www.apxingchi.com);

                Ubuntu:已提供修复补丁(//www.hermxroller.com);

                SUSE:已陆续发布补丁(//www.kaikeim.com);

                Mozilla Firefox:官方新版本已更新(//www.lczrmy.com);

                XEN:已发布安全公告(//www.hnhfx.net);

                QEMU:已发布安全公告(//www.04580458.com),非官方安全补丁(//www.crccltda.com);

                Vmware:发布安全公告及补丁(//www.jingyuexiangsu.com:80);

                Citrix XenServer:发布安全补丁(//www.tjlfd.com);

                亚马逊:已提供修复补丁(//www.youjimoshi.com);

                阿里云:将于2018年1月12日凌晨进行热升级,个别用户可能需要手动重启;

                腾讯云:将于2018年1月10日凌晨进行热升级,个别用户可能需要手动重启。

                 

                附件1:Windows漏洞验证方法

                通过使用微软公司发布的检测PowerShell脚本(https://support.microsoft.com/en-us/help/4073119/protect-against-speculative-execution-side-channel-vulnerabilities-in),可以判断Windows系统是否受漏洞影响。检测方法如下:

                1)安装相应的PowerShell模块,执行命令:PS> Install-Module SpeculationControl

                2)下载并调用相应脚本(//www.chengyegd.com),对应命令:PS> Get-SpeculationControlSettings其中,开启的保护会显示为True,未开启的保护则会显示为False。

                 

                

                闽公网安备 35010002000114号